čtvrtek 7. listopadu 2013

Scoring v Excelu

Funkce FORECAST

Do článku o funkcích pro regresní analýzu jsem doplnil popis funkce FORECAST. Funkce FORECAST slouží k tomu, aby se, na základě lineární regresní závislosti, dopočetla hodnota závislé proměnné (y) na základě hodnoty nezávislé proměnné (x).
Funkce FORECAST má syntaxi FORECAST(hodnota závislé proměnné;oblast s hodnotami x;, oblast s hodnotami y).
Jinými slovy. Dejme tomu, že řeším závislost počtu prodaných kopečků zmrzliny na průměrné denní teplotě. Mám údaje o tom, jak se při kterých teplotách zmrzlina prodávala dříve, a teď zjišťuji, kolik kopečků se prodá při denní teplotě 22 stupňů.
Pak je nezávislou proměnnou teplota a závislou počet kopečků a FORECAST se zapíše takto:

  • =FORECAST(22;oblast s údaji o prodaných kopečcích z minulosti;oblast s údaji o teplotě z minulosti)

Více v článku.

neděle 3. listopadu 2013

Data mining - vysledování závislostí - doplňování dat do tabulky podle vzoru

Dohledání hodnot na základě části textu

Příklad

Představte si, že potřebujete propojit dvě tabulky funkcí SVYHLEDAT (VLOOKUP). Neznáte ale přesné hodnoty - znáte jen části textů, které jsou v dohledávané tabulce. Asi takto:

Řešení

Řešením je kombinace několika funkcí, které dají dohromady tento vzorec:
=INDEX(F:F;POZVYHLEDAT(CONCATENATE("*";A3;"*");E:E;0);0)

  • Funkce CONCATENATE obalí hodnotu z buňky A3 do hvězdiček. To proto, že hvězdička nahrazuje jakýkoliv symbol nebo skupinu symbolů. 
  • Funkce POZVYHLEDAT (MATCH), která ji obaluje, tedy nebude hledat konkrétní hodnotu z buňky A3, ale cokoliv, co hodnotu z A3 obsahuje.
  • V tomto případě by fungoval i jednodušší zápis =SVYHLEDAT(A:A;E:F;2;0). Jeho fungování by ale bylo, jak vyplývá z logiky funkce SVYHLEDAT, omezené jen na situaci, kdy tabulka, ze které čerpám, má hodnoty, ze kterých se páruje, v prvním sloupci.
  • Kombinace funkcí INDEX a POZVYHLEDAT je popsaná tady.

Takto vypadá výsledek:


sobota 2. listopadu 2013

Mapy v Power View

Jako celkem otrlého uživatele Excelu mě jen tak nějaká nová funkce nezaskočí. Co mě ale nadchlo hodně, je způsob prezentace dat v doplňku Power View.
Představte si, že máte jednoduchou tabulku, například s tržbami. Tabulka vypadá takto:
 
S pomocí Power View z ní můžete během pár vteřin udělat interaktivní mapu, ve které uvidíte, jak se kde které produkty sledované firmy prodávaly:

Návod na tvorbu mapových grafů čtěte zde