úterý 31. prosince 2013

Power Pivot - moje nové stránky zabývající se Excelem

Power Pivot se tváří jako obyčejný doplněk Excelu. Ve skutečnosti se ale jedná o velmi zajímavou technologii Business Intelligence.
Osobně Power Pivotu předpovídám slibnou budoucnost. Proto vytvářím nový web, zaměřený pouze na něj.
Některé kapitoly jsou zatím ve stavu "rozpracované", některé kapitoly jsou zatím ve stavu "ještě ani ne rozpracované". Nicméně i tak to je jeden z mála souvislých textů / návodů týkajících se Power Pivotu a myslím, že by to pro Vás jako pro čtenáře webu www.excelentnitriky.com mohlo být inspirativní čtení.
Předem díky za zpětnou vazbu.
Jo a také přeji pěkný příští rok!




sobota 28. prosince 2013

Řazení čísel pomocí funkce

Příklad

Potřebuji seřadit čísla v tabulce. Nechci ale (nebo nemohu) to udělat řazením - potřebuji použít funkci.

Návod

Připravím si někde sloupeček, kde budou čísla od jedničky do tolika, kolik je čísel. Pak do vedlejších sloupečku zapíšu funkci LARGE (řazení od největšího), resp. SMALL (řazení od nejmenšího).
Tato funkce bude mít v prvním parametru oblast, kde jsou původní neseřazená čísla, a ve druhém číslo z vedlejšího sloupce. Toto číslo vyjadřuje, kolikáté největší (nejmenší) číslo se právě na této pozici má zobrazit.


Pokud bych se chtěl obejít bez pomocného sloupečku, mohl by zápis funkce vypadat např. takto:
=LARGE(A:A;ŘÁDEK()-1)
V následujícím příkladu je v praxi použita kombinace funkce SMALL a SVYHLEDAT pro seřazení jmen závodníků podle času, kterého dosáhli:
Zápis funkce pak může vypadat např. takto:
=SVYHLEDAT(SMALL($A$2:$A$7;ŘÁDEK()-1);A:B;2;0)